Rabu, 18 Juli 2012

Depends: but it is not installable


Bagi kawan - kawan yang pernah mengalami hal erorr saat install melalui update repository atau apt-get install.. lalu muncul erorr sebagai berikut ini pidgin : Depends: perlapi-5.12.4 but it is not installable. saya menemui kasus di komputer rekan kerja saya saat install pidgin di ubuntu 12.04.dan walhasil ternyata bukan karena dependensinya kurang atau tidak ada. karena saya mencoba menginstall dependensi perlapi-5.12.4 tapi tidak berhasil... ternyata setelah saya cek di sourcelistnya ada kejanggalan yakni harusnya sourcelist tersebut seperti berikut :

deb http://kambing.ui.ac.id/ubuntu/ precise-proposed main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise-security main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise-updates main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise main restricted universe multiverse

ternyata letak kesalahannya adalah

deb http://kambing.ui.ac.id/ubuntu/ precise-proposed main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise-security main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise-updates main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ onieric main restricted universe multiverse

dan itulah mengapa terjadi erorr dependensi yang tidak ditemukan saat install melalui repositori. maka gantilah dan sesuaikan dengan source list yang ada dengan versi ubuntu anda. 

Terima kasih...semoga bermanfaat.....>>>>>


Tidak ada komentar:

Poskan Komentar